[kubuntu] 9.10 y Galileo


Un mes escaso llevo con Eclipse, soy de la vieja escuela y tiraba del olvidado JBuilder (IDE al que le tengo un cariño especial) así que, para variar, decidí instalarlo en casa en Kubuntu 9.10. Las cosas de la crisis que hacen que Analistas nos pongamos a picar código, OJO, no lo digo en tono despectivo ni nada parecido, en mis 10 añitos ya en esta profesión no he dejado de picar tecla, de hecho, épocas en las que he estado un poco más apartado de esta labor he acabado echando de menos el vicio ;-)

Instalarlo es de lo más fácil, visitas la página oficial de Eclipse y descargas la versión que más se adapte a tus necesidades. En particular he descargado Eclipse IDE for Java EE Developers (188 MB) para GNU/Linux claro está. El resultado un .gz que sólo debes descomprimir donde más te guste.

Una vez hecho esto resulta que, por cosas de la vida que puedes investigar googleando un poco, los botones de acción en Ubuntu/Kubuntu no acaban de funcionar, por suerte y gracias a que ésta es una gran comunidad se puede resolver fácilmente. En mi caso topé con la respuesta en UbuntuLife (cada día me gusta más ese blog y aunque nuestro superpiwi lleva unos días de bajón, espero que el mini-parón que está haciendo le sirva para encontrar el camino donde luzca el sol para él).

Bien, el tip es sencillo…generas un script con las siguientes lineas y ya puedes lanzar Eclipse con los botones dichosos operativos.

#!/bin/sh
export GDK_NATIVE_WINDOWS=1
/RUTA_DONDE_TIENES_ECLIPSE/eclipse

La cosa es que con la versión “Europa” que estaba utilizando no acaba de funcionar este tip pero, con Galileo, funciona sin problemas ^_^ Espero que os sirva de algo.